SR drivability issue

Tech mumbo-jumbo... not Gizmodo.

Moderators: charlie, darkducati

Post Reply
MS13
Fresh Meat
Posts: 15
Joined: Tue Jan 20, 2009 3:23 pm
Location: B`HAM, Al.

SR drivability issue

Post by MS13 »

I have a redtop sr20det problem that i can`t figure out. While driving, accelerating or cruising, the engine will just stop accelerating, let off the pedal, press it back to the floor and nothing for a few seconds then it takes off again. Keep driving and it just gets worse. I unplug my TPS, then plug it back in(which causes ECM to stop taking sensor info and uses set values in the ecm) and it will run fine for 3 or 4 days except for a high idle then act up again. It never idles right since having this problem and the throttle response is horrible. I dont know if the laggy throttle is related or not but i know more information always helps. Anyone had this problem? or just know what i can look for?


I did change the TPS with a friends and had same problem although his sensor was just one he had sitting around, so no guarantee that it was good.
User avatar
Rhoad Racing
Salsa Rodeo
Posts: 5780
Joined: Fri Jun 04, 2004 4:51 pm
Location: Sisu.
Contact:

Re: SR drivability issue

Post by Rhoad Racing »

Im sorry. Did you make a wrong turn at Albuquerque?
User avatar
TurboGrinch
Imitation Crab Meat
Posts: 512
Joined: Wed Sep 30, 2009 2:19 am
Location: Siegburg / germany
Contact:

Re: SR drivability issue

Post by TurboGrinch »

have you reseted the TPS?

any more infos, what does the boost do, when the car gets slower, whats the afr doing? Is it just like you lift the throttle or ist the engine shaking?

Martin
Image
matts13
OK Finally Past the Hazing
Posts: 1925
Joined: Mon Jan 09, 2006 8:31 pm
Location: Woodstick

Re: SR drivability issue

Post by matts13 »

try cleaning/new maf.
MS13
Fresh Meat
Posts: 15
Joined: Tue Jan 20, 2009 3:23 pm
Location: B`HAM, Al.

Re: SR drivability issue

Post by MS13 »

TurboGrinch wrote:have you reseted the TPS?

any more infos, what does the boost do, when the car gets slower, whats the afr doing? Is it just like you lift the throttle or ist the engine shaking?

Martin
Never payed much attention to the boost but i think it just goes to normal engine vacuum, like you just lifted out of the throttle. I don't have anything to monitor the AFR. The engine stays the same, just like you let of the accelerator.

and yes i reset the TPS back to within the voltage spec.
User avatar
struka
Slippery When Westicles
Posts: 8257
Joined: Sat Oct 02, 2004 7:59 pm
Location: Rocketbrah

Re: SR drivability issue

Post by struka »

Image
User avatar
andysapp
I need to go outside
Posts: 28825
Joined: Wed Apr 07, 2004 5:07 pm
Location: KILL 'EM ALL.

Re: SR drivability issue

Post by andysapp »

LOL> ^^
Post Reply